// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d+.)+ (\w)").unwrap();
let string = "1.43.7.112. Teste.
26.0.177. Teste.
1.1.1.1.1. Teste. Teste1.
1.1.1.1. Teste
1. Teste
1.43.7.112. Teste. 1.43.7.112. Teste.
1.43.7.112.
1.43.7.112. 123teste
1.43.7.112. _este.";
let substitution = "$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}