re = /(\d+.)+ (\w)/
str = '1.43.7.112. Teste.
26.0.177. Teste.
1.1.1.1.1. Teste. Teste1.
1.1.1.1. Teste
1. Teste
1.43.7.112. Teste. 1.43.7.112. Teste.
1.43.7.112.
1.43.7.112. 123teste
1.43.7.112. _este.'
subst = '$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result