import Foundation
let pattern = #"(\d+.)+ (\w)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1.43.7.112. Teste.
26.0.177. Teste.
1.1.1.1.1. Teste. Teste1.
1.1.1.1. Teste
1. Teste
1.43.7.112. Teste. 1.43.7.112. Teste.
1.43.7.112.
1.43.7.112. 123teste
1.43.7.112. _este.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)