#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?P<host>\d{1,3}.\d{1,3}.\d{1,3}.\d{1,3})(\s-\s)(?P<user_name>[\w-]*)(\s\[)(?P<time>\w*\/\w*\/\d{1,4}:\d{1,2}:\d{1,2}:\d{1,2}\s-\d{1,4})(\]\s\")(?P<request>.*)(")"
Local $sString = "146.204.224.152 - feest6811 [21/Jun/2019:15:45:24 -0700] "POST /incentivize HTTP/1.1" 302 4622" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")