import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<host>\\d{1,3}.\\d{1,3}.\\d{1,3}.\\d{1,3})(\\s-\\s)(?P<user_name>[\\w-]*)(\\s\\[)(?P<time>\\w*\\/\\w*\\/\\d{1,4}:\\d{1,2}:\\d{1,2}:\\d{1,2}\\s-\\d{1,4})(\\]\\s\\\")(?P<request>.*)(\")";
final String string = "146.204.224.152 - feest6811 [21/Jun/2019:15:45:24 -0700] \"POST /incentivize HTTP/1.1\" 302 4622\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}