package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<host>\d{1,3}.\d{1,3}.\d{1,3}.\d{1,3})(\s-\s)(?P<user_name>[\w-]*)(\s\[)(?P<time>\w*\/\w*\/\d{1,4}:\d{1,2}:\d{1,2}:\d{1,2}\s-\d{1,4})(\]\s\")(?P<request>.*)(")`)
var str = `146.204.224.152 - feest6811 [21/Jun/2019:15:45:24 -0700] "POST /incentivize HTTP/1.1" 302 4622
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}