const regex = /(?P<host>\d{1,3}.\d{1,3}.\d{1,3}.\d{1,3})(\s-\s)(?P<user_name>[\w-]*)(\s\[)(?P<time>\w*\/\w*\/\d{1,4}:\d{1,2}:\d{1,2}:\d{1,2}\s-\d{1,4})(\]\s\")(?P<request>.*)(")/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<host>\\d{1,3}.\\d{1,3}.\\d{1,3}.\\d{1,3})(\\s-\\s)(?P<user_name>[\\w-]*)(\\s\\[)(?P<time>\\w*\\\/\\w*\\\/\\d{1,4}:\\d{1,2}:\\d{1,2}:\\d{1,2}\\s-\\d{1,4})(\\]\\s\\")(?P<request>.*)(")', 'gm')
const str = `146.204.224.152 - feest6811 [21/Jun/2019:15:45:24 -0700] "POST /incentivize HTTP/1.1" 302 4622
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}