using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<host>\d{1,3}.\d{1,3}.\d{1,3}.\d{1,3})(\s-\s)(?P<user_name>[\w-]*)(\s\[)(?P<time>\w*\/\w*\/\d{1,4}:\d{1,2}:\d{1,2}:\d{1,2}\s-\d{1,4})(\]\s\"")(?P<request>.*)("")";
string input = @"146.204.224.152 - feest6811 [21/Jun/2019:15:45:24 -0700] ""POST /incentivize HTTP/1.1"" 302 4622
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}