// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?P<host>\d{1,3}.\d{1,3}.\d{1,3}.\d{1,3})(\s-\s)(?P<user_name>[\w-]*)(\s\[)(?P<time>\w*\/\w*\/\d{1,4}:\d{1,2}:\d{1,2}:\d{1,2}\s-\d{1,4})(\]\s\")(?P<request>.*)(")"#).unwrap();
let string = "146.204.224.152 - feest6811 [21/Jun/2019:15:45:24 -0700] \"POST /incentivize HTTP/1.1\" 302 4622
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}