#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?-s)^(\w+=)(?:(.*?);;){9}.*"
Local $sString = "HUD_Menu_Options_Audio=Audio;;Audio;;Son;;Audio;;Audio;;Zvuk;;Hang;;Dźwięk;;Аудио;;音效;" & @CRLF & _
"HUD_Menu_Options_Controls=Controls;;Controlli;;Commandes;;Steuerung;;Controles;;Ovládání;;Irányítás;;Ster owanie;;Управление;;操控;" & @CRLF & _
"Должно превратиться вот в это:" & @CRLF & _
"HUD_Menu_Options_Audio=Аудио" & @CRLF & _
"HUD_Menu_Options_Controls=Управление" & @CRLF & _
"И так со всеми строчками. Есть ли какой-нибудь способ такое сделать? "
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)