const regex = /(?-s)^(\w+=)(?:(.*?);;){9}.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?-s)^(\\w+=)(?:(.*?);;){9}.*', 'gm')
const str = `HUD_Menu_Options_Audio=Audio;;Audio;;Son;;Audio;;Audio;;Zvuk;;Hang;;Dźwięk;;Аудио;;音效;
HUD_Menu_Options_Controls=Controls;;Controlli;;Commandes;;Steuerung;;Controles;;Ovládání;;Irányítás;;Ster owanie;;Управление;;操控;
Должно превратиться вот в это:
HUD_Menu_Options_Audio=Аудио
HUD_Menu_Options_Controls=Управление
И так со всеми строчками. Есть ли какой-нибудь способ такое сделать? `;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);