import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?-s)^(\\w+=)(?:(.*?);;){9}.*";
final String string = "HUD_Menu_Options_Audio=Audio;;Audio;;Son;;Audio;;Audio;;Zvuk;;Hang;;Dźwięk;;Аудио;;音效;\n"
+ "HUD_Menu_Options_Controls=Controls;;Controlli;;Commandes;;Steuerung;;Controles;;Ovládání;;Irányítás;;Ster owanie;;Управление;;操控;\n"
+ "Должно превратиться вот в это:\n"
+ "HUD_Menu_Options_Audio=Аудио\n"
+ "HUD_Menu_Options_Controls=Управление\n"
+ "И так со всеми строчками. Есть ли какой-нибудь способ такое сделать? ";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}