$re = '/(?-s)^(\w+=)(?:(.*?);;){9}.*/m';
$str = 'HUD_Menu_Options_Audio=Audio;;Audio;;Son;;Audio;;Audio;;Zvuk;;Hang;;Dźwięk;;Аудио;;音效;
HUD_Menu_Options_Controls=Controls;;Controlli;;Commandes;;Steuerung;;Controles;;Ovládání;;Irányítás;;Ster owanie;;Управление;;操控;
Должно превратиться вот в это:
HUD_Menu_Options_Audio=Аудио
HUD_Menu_Options_Controls=Управление
И так со всеми строчками. Есть ли какой-нибудь способ такое сделать? ';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;