# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?-s)^(\w+=)(?:(.*?);;){9}.*"
test_str = ("HUD_Menu_Options_Audio=Audio;;Audio;;Son;;Audio;;Audio;;Zvuk;;Hang;;Dźwięk;;Аудио;;音效;\n"
"HUD_Menu_Options_Controls=Controls;;Controlli;;Commandes;;Steuerung;;Controles;;Ovládání;;Irányítás;;Ster owanie;;Управление;;操控;\n"
"Должно превратиться вот в это:\n"
"HUD_Menu_Options_Audio=Аудио\n"
"HUD_Menu_Options_Controls=Управление\n"
"И так со всеми строчками. Есть ли какой-нибудь способ такое сделать? ")
subst = "$1$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.