use strict;
my $str = 'HUD_Menu_Options_Audio=Audio;;Audio;;Son;;Audio;;Audio;;Zvuk;;Hang;;Dźwięk;;Аудио;;音效;
HUD_Menu_Options_Controls=Controls;;Controlli;;Commandes;;Steuerung;;Controles;;Ovládání;;Irányítás;;Ster owanie;;Управление;;操控;
Должно превратиться вот в это:
HUD_Menu_Options_Audio=Аудио
HUD_Menu_Options_Controls=Управление
И так со всеми строчками. Есть ли какой-нибудь способ такое сделать? ';
my $regex = qr/(?-s)^(\w+=)(?:(.*?);;){9}.*/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";