using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?-s)^(\w+=)(?:(.*?);;){9}.*";
string substitution = @"$1$2";
string input = @"HUD_Menu_Options_Audio=Audio;;Audio;;Son;;Audio;;Audio;;Zvuk;;Hang;;Dźwięk;;Аудио;;音效;
HUD_Menu_Options_Controls=Controls;;Controlli;;Commandes;;Steuerung;;Controles;;Ovládání;;Irányítás;;Ster owanie;;Управление;;操控;
Должно превратиться вот в это:
HUD_Menu_Options_Audio=Аудио
HUD_Menu_Options_Controls=Управление
И так со всеми строчками. Есть ли какой-нибудь способ такое сделать? ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}