#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\b([0-9]{10}|[0-9\s]{12})\b)"
Local $sString = "KINDLY AUTH FOR FUNDS" & @CRLF & _
"ACC 1469007967 (Number needs to be extracted)" & @CRLF & _
"" & @CRLF & _
"KINDLY AUTH FOR FUNDS" & @CRLF & _
"ACC 146900796723423 **(Want to ignore this number)**" & @CRLF & _
"" & @CRLF & _
"ACC NUMBER -1186 057 378 **(the number after - sign needs to be extracted)**" & @CRLF & _
"" & @CRLF & _
"**1162792833** CHQ:104-R8856.00 AND (The number in ** needs to be extracted)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")