use strict;
my $str = 'KINDLY AUTH FOR FUNDS
ACC 1469007967 (Number needs to be extracted)
KINDLY AUTH FOR FUNDS
ACC 146900796723423 **(Want to ignore this number)**
ACC NUMBER -1186 057 378 **(the number after - sign needs to be extracted)**
**1162792833** CHQ:104-R8856.00 AND (The number in ** needs to be extracted)';
my $regex = qr/(\b([0-9]{10}|[0-9\s]{12})\b)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}