re = /(\b([0-9]{10}|[0-9\s]{12})\b)/m
str = 'KINDLY AUTH FOR FUNDS
ACC 1469007967 (Number needs to be extracted)
KINDLY AUTH FOR FUNDS
ACC 146900796723423 **(Want to ignore this number)**
ACC NUMBER -1186 057 378 **(the number after - sign needs to be extracted)**
**1162792833** CHQ:104-R8856.00 AND (The number in ** needs to be extracted)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end