import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\b([0-9]{10}|[0-9\\s]{12})\\b)";
final String string = "KINDLY AUTH FOR FUNDS\n"
+ "ACC 1469007967 (Number needs to be extracted)\n\n"
+ "KINDLY AUTH FOR FUNDS\n"
+ "ACC 146900796723423 **(Want to ignore this number)**\n\n"
+ "ACC NUMBER -1186 057 378 **(the number after - sign needs to be extracted)**\n\n"
+ "**1162792833** CHQ:104-R8856.00 AND (The number in ** needs to be extracted)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}