// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\b([0-9]{10}|[0-9\s]{12})\b)").unwrap();
let string = "KINDLY AUTH FOR FUNDS
ACC 1469007967 (Number needs to be extracted)
KINDLY AUTH FOR FUNDS
ACC 146900796723423 **(Want to ignore this number)**
ACC NUMBER -1186 057 378 **(the number after - sign needs to be extracted)**
**1162792833** CHQ:104-R8856.00 AND (The number in ** needs to be extracted)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}