#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.+?)[ ]+(\d+)[ ]*:[ ]*(\d+)[ ]+(.+)"
Local $sString = "My Team U19 14 : 1 Team A" & @CRLF & _
"Myeam 74 : 15 Team D U18" & @CRLF & _
"T 2 : 1 Team A" & @CRLF & _
"Meam 10 : 1 Tem A" & @CRLF & _
"Myam U20 4 : 10 Te A" & @CRLF & _
"MTeam 6 : 1 Tea A" & @CRLF & _
"My 4 : 1 Team A" & @CRLF & _
"Mybeam U16 45 : 1 Tbgm A U16" & @CRLF & _
"M 12 : 1 Tm A"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")