re = /(.+?)[ ]+(\d+)[ ]*:[ ]*(\d+)[ ]+(.+)/m
str = 'My Team U19 14 : 1 Team A
Myeam 74 : 15 Team D U18
T 2 : 1 Team A
Meam 10 : 1 Tem A
Myam U20 4 : 10 Te A
MTeam 6 : 1 Tea A
My 4 : 1 Team A
Mybeam U16 45 : 1 Tbgm A U16
M 12 : 1 Tm A'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end