import re
regex = re.compile(r"(.+?)[ ]+(\d+)[ ]*:[ ]*(\d+)[ ]+(.+)", flags=re.MULTILINE)
test_str = ("My Team U19 14 : 1 Team A\n"
"Myeam 74 : 15 Team D U18\n"
"T 2 : 1 Team A\n"
"Meam 10 : 1 Tem A\n"
"Myam U20 4 : 10 Te A\n"
"MTeam 6 : 1 Tea A\n"
"My 4 : 1 Team A\n"
"Mybeam U16 45 : 1 Tbgm A U16\n"
"M 12 : 1 Tm A")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")