import Foundation
let pattern = #"(.+?)[ ]+(\d+)[ ]*:[ ]*(\d+)[ ]+(.+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
My Team U19 14 : 1 Team A
Myeam 74 : 15 Team D U18
T 2 : 1 Team A
Meam 10 : 1 Tem A
Myam U20 4 : 10 Te A
MTeam 6 : 1 Tea A
My 4 : 1 Team A
Mybeam U16 45 : 1 Tbgm A U16
M 12 : 1 Tm A
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)