use strict;
my $str = 'My Team U19 14 : 1 Team A
Myeam 74 : 15 Team D U18
T 2 : 1 Team A
Meam 10 : 1 Tem A
Myam U20 4 : 10 Te A
MTeam 6 : 1 Tea A
My 4 : 1 Team A
Mybeam U16 45 : 1 Tbgm A U16
M 12 : 1 Tm A';
my $regex = qr/(.+?)[ ]+(\d+)[ ]*:[ ]*(\d+)[ ]+(.+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}