using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.+?)[ ]+(\d+)[ ]*:[ ]*(\d+)[ ]+(.+)";
string input = @"My Team U19 14 : 1 Team A
Myeam 74 : 15 Team D U18
T 2 : 1 Team A
Meam 10 : 1 Tem A
Myam U20 4 : 10 Te A
MTeam 6 : 1 Tea A
My 4 : 1 Team A
Mybeam U16 45 : 1 Tbgm A U16
M 12 : 1 Tm A";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}