#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "script src=["']?(\w+\.js)"
Local $sString = "var a = '<script class="anyClass" src="anyFile.js" id="anyID">';" & @CRLF & _
"var b = '<script class="anyClass" src="anyFile.js">';" & @CRLF & _
"var c = '<script src="anyFile.js" id="anyID">';" & @CRLF & _
"var d = '<script src="anyFile.js">';" & @CRLF & _
"" & @CRLF & _
"var e = "<script class='anyClass' src='anyFile.js' id='anyID'>";" & @CRLF & _
"var f = "<script class='anyClass' src='anyFile.js'>";" & @CRLF & _
"var g = "<script src='anyFile.js' id='anyID'>";" & @CRLF & _
"var h = "<script src='anyFile.js'>";" & @CRLF & _
"" & @CRLF & _
"var i= "<script class=anyClass src=anyFile.js id=anyID>";" & @CRLF & _
"var j= "<script class=anyClass src=anyFile.js>";" & @CRLF & _
"var k= "<script src=anyFile.js id=anyID>";" & @CRLF & _
"var l= "<script src=anyFile.js>";"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")