import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "script src=[\"']?(\\w+\\.js)";
final String string = "var a = '<script class=\"anyClass\" src=\"anyFile.js\" id=\"anyID\">';\n"
+ "var b = '<script class=\"anyClass\" src=\"anyFile.js\">';\n"
+ "var c = '<script src=\"anyFile.js\" id=\"anyID\">';\n"
+ "var d = '<script src=\"anyFile.js\">';\n\n"
+ "var e = \"<script class='anyClass' src='anyFile.js' id='anyID'>\";\n"
+ "var f = \"<script class='anyClass' src='anyFile.js'>\";\n"
+ "var g = \"<script src='anyFile.js' id='anyID'>\";\n"
+ "var h = \"<script src='anyFile.js'>\";\n\n"
+ "var i= \"<script class=anyClass src=anyFile.js id=anyID>\";\n"
+ "var j= \"<script class=anyClass src=anyFile.js>\";\n"
+ "var k= \"<script src=anyFile.js id=anyID>\";\n"
+ "var l= \"<script src=anyFile.js>\";";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}