re = /script src=["']?(\w+\.js)/
str = 'var a = \'<script class="anyClass" src="anyFile.js" id="anyID">\';
var b = \'<script class="anyClass" src="anyFile.js">\';
var c = \'<script src="anyFile.js" id="anyID">\';
var d = \'<script src="anyFile.js">\';
var e = "<script class=\'anyClass\' src=\'anyFile.js\' id=\'anyID\'>";
var f = "<script class=\'anyClass\' src=\'anyFile.js\'>";
var g = "<script src=\'anyFile.js\' id=\'anyID\'>";
var h = "<script src=\'anyFile.js\'>";
var i= "<script class=anyClass src=anyFile.js id=anyID>";
var j= "<script class=anyClass src=anyFile.js>";
var k= "<script src=anyFile.js id=anyID>";
var l= "<script src=anyFile.js>";'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end