# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"script src=[\"']?(\w+\.js)"
test_str = ("var a = '<script class=\"anyClass\" src=\"anyFile.js\" id=\"anyID\">';\n"
"var b = '<script class=\"anyClass\" src=\"anyFile.js\">';\n"
"var c = '<script src=\"anyFile.js\" id=\"anyID\">';\n"
"var d = '<script src=\"anyFile.js\">';\n\n"
"var e = \"<script class='anyClass' src='anyFile.js' id='anyID'>\";\n"
"var f = \"<script class='anyClass' src='anyFile.js'>\";\n"
"var g = \"<script src='anyFile.js' id='anyID'>\";\n"
"var h = \"<script src='anyFile.js'>\";\n\n"
"var i= \"<script class=anyClass src=anyFile.js id=anyID>\";\n"
"var j= \"<script class=anyClass src=anyFile.js>\";\n"
"var k= \"<script src=anyFile.js id=anyID>\";\n"
"var l= \"<script src=anyFile.js>\";")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.