using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"script src=[""']?(\w+\.js)";
string input = @"var a = '<script class=""anyClass"" src=""anyFile.js"" id=""anyID"">';
var b = '<script class=""anyClass"" src=""anyFile.js"">';
var c = '<script src=""anyFile.js"" id=""anyID"">';
var d = '<script src=""anyFile.js"">';
var e = ""<script class='anyClass' src='anyFile.js' id='anyID'>"";
var f = ""<script class='anyClass' src='anyFile.js'>"";
var g = ""<script src='anyFile.js' id='anyID'>"";
var h = ""<script src='anyFile.js'>"";
var i= ""<script class=anyClass src=anyFile.js id=anyID>"";
var j= ""<script class=anyClass src=anyFile.js>"";
var k= ""<script src=anyFile.js id=anyID>"";
var l= ""<script src=anyFile.js>"";";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}