// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"script src=["']?(\w+\.js)"#).unwrap();
let string = "var a = '<script class=\"anyClass\" src=\"anyFile.js\" id=\"anyID\">';
var b = '<script class=\"anyClass\" src=\"anyFile.js\">';
var c = '<script src=\"anyFile.js\" id=\"anyID\">';
var d = '<script src=\"anyFile.js\">';
var e = \"<script class='anyClass' src='anyFile.js' id='anyID'>\";
var f = \"<script class='anyClass' src='anyFile.js'>\";
var g = \"<script src='anyFile.js' id='anyID'>\";
var h = \"<script src='anyFile.js'>\";
var i= \"<script class=anyClass src=anyFile.js id=anyID>\";
var j= \"<script class=anyClass src=anyFile.js>\";
var k= \"<script src=anyFile.js id=anyID>\";
var l= \"<script src=anyFile.js>\";";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}