use strict;
my $str = 'var a = \'<script class="anyClass" src="anyFile.js" id="anyID">\';
var b = \'<script class="anyClass" src="anyFile.js">\';
var c = \'<script src="anyFile.js" id="anyID">\';
var d = \'<script src="anyFile.js">\';
var e = "<script class=\'anyClass\' src=\'anyFile.js\' id=\'anyID\'>";
var f = "<script class=\'anyClass\' src=\'anyFile.js\'>";
var g = "<script src=\'anyFile.js\' id=\'anyID\'>";
var h = "<script src=\'anyFile.js\'>";
var i= "<script class=anyClass src=anyFile.js id=anyID>";
var j= "<script class=anyClass src=anyFile.js>";
var k= "<script src=anyFile.js id=anyID>";
var l= "<script src=anyFile.js>";';
my $regex = qr/script src=["']?(\w+\.js)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}