const regex = new RegExp('(\\b\\d\\b)', 'g')
const str = `8 5E 9C 52 30 0`;
const subst = `0\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);