$re = '/(\b\d\b)/';
$str = '8 5E 9C 52 30 0';
$subst = "0\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;