import Foundation
let pattern = #"(\b\d\b)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"8 5E 9C 52 30 0"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"0\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)