use strict;
my $str = '8 5E 9C 52 30 0';
my $regex = qr/(\b\d\b)/p;
my $subst = '0\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";