# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\\)\$([^\W$]+)//g;t' <<< "test $test1 testagain$test2 testyetagain $test3 $test4$test5 \\$1.00"