#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<!\\)\$([^\W$]+)"
Local $sString = "test $test1 testagain$test2 testyetagain $test3 $test4$test5 \\$1.00"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)