$re = '/(?<!\\\\)\$([^\W$]+)/';
$str = 'test $test1 testagain$test2 testyetagain $test3 $test4$test5 \\\\$1.00';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;