const regex = /(?<!\\)\$([^\W$]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\\\)\\$([^\\W$]+)', 'g')
const str = `test \$test1 testagain\$test2 testyetagain \$test3 \$test4\$test5 \\\\\$1.00`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);