using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\\)\$([^\W$]+)";
string substitution = @"";
string input = @"test $test1 testagain$test2 testyetagain $test3 $test4$test5 \\$1.00";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}