import Foundation
let pattern = #"(?<!\\)\$([^\W$]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"test $test1 testagain$test2 testyetagain $test3 $test4$test5 \\$1.00"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)