re = /(?<!\\)\$([^\W$]+)/
str = 'test $test1 testagain$test2 testyetagain $test3 $test4$test5 \\\\$1.00'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result