# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<bs-icon (?<attr>[^>]+)><\/bs-icon>/<svg $1><\/svg>/gm;t' <<< "<bs-icon class=\"bi\" icon=\"book-half\" title=\"My Icon Title\"></bs-icon>
<bs-icon class=\"bi\" icon=\"book-half\" title=\"My Icon Title\"></bs-icon>"