use strict;
my $str = '<bs-icon class="bi" icon="book-half" title="My Icon Title"></bs-icon>
<bs-icon class="bi" icon="book-half" title="My Icon Title"></bs-icon>';
my $regex = qr#<bs-icon (?<attr>[^>]+)></bs-icon>#mp;
my $subst = '<svg $1></svg>';
my $result = $str =~ s#$regex#$subst#rg;
print "The result of the substitution is' $result\n";