package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<bs-icon (?<attr>[^>]+)></bs-icon>`)
var str = `<bs-icon class="bi" icon="book-half" title="My Icon Title"></bs-icon>
<bs-icon class="bi" icon="book-half" title="My Icon Title"></bs-icon>`
var substitution = "<svg $1></svg>"
fmt.Println(re.ReplaceAllString(str, substitution))
}