using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<bs-icon (?<attr>[^>]+)></bs-icon>";
string substitution = @"<svg $1></svg>";
string input = @"<bs-icon class=""bi"" icon=""book-half"" title=""My Icon Title""></bs-icon>
<bs-icon class=""bi"" icon=""book-half"" title=""My Icon Title""></bs-icon>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}