import Foundation
let pattern = #"<bs-icon (?<attr>[^>]+)></bs-icon>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<bs-icon class="bi" icon="book-half" title="My Icon Title"></bs-icon>
<bs-icon class="bi" icon="book-half" title="My Icon Title"></bs-icon>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<svg $1></svg>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)